Opened 9 years ago

Closed 7 years ago

#455 closed defect (fixed)

pandora's sqlite3.import.scm file tries to import synch

Reported by: Christian Kellermann Owned by: Thomas Chust
Priority: major Milestone:
Component: extensions Version: 4.6.x
Keywords: Cc:
Estimated difficulty:

Description

The import statement for pandora's sqlite3.import.scm file is wrong. Has this been written manually?

Why is synch there needed?

Change History (4)

comment:1 Changed 9 years ago by felix winkelmann

Milestone: 4.7.0

comment:2 Changed 9 years ago by felix winkelmann

I removed the import libraries, since it is definitely incorrect to add them to the egg sources. The problem is likely to be that the author didn't want to have dependencies on sqlite3 AND postgresql (and all other future DB APIs). I'm not sure how to address this.

comment:3 Changed 9 years ago by felix winkelmann

One solution would be to detect installed database eggs in the .setup script and compile the appropriate wrappers. This means, some DB egg must be installed before pandora can be compiled.

comment:4 Changed 7 years ago by Thomas Chust

Resolution: fixed
Status: newclosed

This problem is not present in the trunk version of pandora.

Note: See TracTickets for help on using tickets.