Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#456 closed defect (wontfix)

uuid-ossp does not build on test.call-cc.org

Reported by: Christian Kellermann Owned by: Kon Lovett
Priority: major Milestone: 4.9.0
Component: extensions Version: 4.6.x
Keywords: Cc:
Estimated difficulty:

Description

I just noticed this on salmonella:

http://tests.call-cc.org/2010/12/16/salmonella-report/uuid-ossp.html

I reproduced the error with trunk but got an additional line:

/usr/local/bin/csc -feature compiling-extension -setup-mode -k uuid-ossp.scm -shared -optimize-leaf-routines -inline -output-file uuid-ossp.so -emit-import-library uuid-ossp -scrutinize -fixnum-arithmetic -optimize-level 3 -debug-level 1 -no-procedure-checks -no-bound-checks uuid-config --cflags uuid-ossp-fix.c uuid-config --ldflags --libs

sh: uuid-config: command not found
sh: uuid-config: command not found
uuid-ossp.c: In function ‘f_1100’:
uuid-ossp.c:1958: error: syntax error before ‘%’ token
uuid-ossp.c:1958: error: syntax error before ‘)’ token
uuid-ossp.c: In function ‘f_1103’:
uuid-ossp.c:1977: error: syntax error before ‘%’ token

Is there an external program / lib needed we need to install there?

Change History (3)

comment:1 Changed 9 years ago by Kon Lovett

Resolution: wontfix
Status: newclosed

1) The 2010/12/16/salmonella-report failure is due to a minor (but in this case fatal) Chicken compiler bug.

2) The uuid-config program is part of the OSSP uuid library installation. See http://www.ossp.org/pkg/lib/uuid/.

3) The egg doc does state "Requires at least release 1.5.0 of the OSSP UUID Library." But there isn't any attempt to check existence on the part of the install, except by failure.

comment:2 Changed 9 years ago by felix winkelmann

Milestone: 4.7.04.8.0

Milestone 4.7.0 deleted

comment:3 Changed 7 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.