Opened 10 years ago

Closed 9 years ago

#682 closed defect (fixed)

sendfile egg has no trunk branch

Reported by: Alan Post Owned by: certainty
Priority: minor Milestone:
Component: extensions Version: 4.7.x
Keywords: Cc:
Estimated difficulty:

Description

I ran the following command-line:

chicken-install -sudo -trunk -location "$CHICKEN_EGG_REPOSITORY" -transport local sendfile

which produced the following error message:

retrieving ...

sendfile located at /opt/chicken-master/src/eggs/sendfile

Warning: extension `sendfile' has no .meta file - assuming it has no dependencies
install order:
()

looking at the repository, sendfile has no trunk branch, but only release branches. Either sendfile needs to have a trunk branch or the bug in chicken-install needs to be fixed to hand an egg formatted like sendfile. I expected it to either complain about a missing trunk or install version 1.7.3 (the latest version).

Change History (5)

comment:1 Changed 10 years ago by felix winkelmann

Milestone: 4.8.0

comment:2 Changed 9 years ago by sjamaan

The problem is that this egg moved to another, external repository; 1.7.3 is most definitely _not_ the latest version.

I'm unsure what the proper fix would be. Probably "svn rm sendfile". Of course, that would obliterate the historical repo (otoh, it can be pulled out of the svn history). It would at least solve some of the confusion users might have.

This hasn't been much of a problem with other eggs because most egg authors decided to keep developing existing eggs in svn and only use alternate DVCSes for new eggs.

David, what do you think?

comment:3 Changed 9 years ago by sjamaan

Owner: set to certainty
Status: newassigned

comment:4 in reply to:  2 Changed 9 years ago by certainty

Hi Alan and Peter,

Sorry for being so late on this subject,
the important information was given by Peter so i hope it's not an immediate issue anymore.

Originally i wanted to keep the svn repository so that eggs that rely on sendfile in a version,
that has been developed in svn can still access it. I don't know if there are any though.
I think spiffy is pretty much the only other egg that uses sendfile.

I've added a repisitory section to the wiki documentation, to mitigate the problem.

If leaving it there confuses more than it helps, we can svn rm it.

Again sorry for being so late.
Cheers David

comment:5 Changed 9 years ago by sjamaan

Resolution: fixed
Status: assignedclosed

I'm closing this ticket, I think the situation is under control :)

Note: See TracTickets for help on using tickets.