Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#610 closed defect (fixed)

srfi-41 segfaults on non-stream cdr

Reported by: Jim Ursetto Owned by: Kon Lovett
Priority: minor Milestone: 4.9.0
Component: extensions Version: 4.7.x
Keywords: Cc:
Estimated difficulty:

Description

Quickest way I can reproduce this:

(use srfi-41)
(stream-null? (stream-cdr (stream-cons 1 2))
Process scheme segmentation fault

(stream-cons 1 2) is illegal but should not segfault when dereferenced.

Change History (2)

comment:1 Changed 10 years ago by Kon Lovett

Resolution: fixed
Status: newclosed

Fixed in 1.2.2.

#;2> (stream-null? (stream-cdr (stream-cons 1 2)))

Error: bad argument type - not a stream: 2

Report will potentially be very "far" from point of actual error. Since lazy execution of tail will not discover type mismatch until forced.

comment:2 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.