Opened 10 years ago

Closed 9 years ago

#76 closed defect (fixed)

numbers egg comparison of a bignum & a flonum can be incorrect

Reported by: Kon Lovett Owned by:
Priority: major Milestone:
Component: extensions Version: 4.2.x
Keywords: Cc:
Estimated difficulty:

Description

(< 1237940039285380274899124223 1237940039285380274899124224.0) ;=> #t

but

(< 1237940039285380274899124224.0 1237940039285380274899124225) ;=> #f

This is caused by using the flonum domain for all comparisons involving bignums.

(exact->inexact 1237940039285380274899124225) ;=> 1237940039285380274899124224.0

Change History (1)

comment:1 Changed 9 years ago by sjamaan

Resolution: fixed
Status: newclosed

Please try out the latest release (2.0). This bug is fixed there.

Note: See TracTickets for help on using tickets.