Opened 10 years ago

Closed 9 years ago

#615 closed defect (worksforme)

openssl dies after about a day

Reported by: Moritz Heidkamp Owned by:
Priority: major Milestone:
Component: unknown Version: 4.7.x
Keywords: openssl Cc:
Estimated difficulty:

Description

Keeping an openssl connection open for about one day leads to the error "SSL socket already closed" being thrown. Since it has no specific condition type it cannot be handled appropriately. The openssl egg should probably not handle this condition specifically anyway but try to write to the closed socket and just let the error raised by the tcp unit propagate.

Change History (7)

comment:1 Changed 10 years ago by sjamaan

I think the main problem is that it's reinvoking {{startup}} after the socket & tcp connection has been marked closed. It shouldn't do that.

comment:2 Changed 10 years ago by sjamaan

The only way I'm able to reproduce this is if I catch and ignore the handshake timeout exception and then re-use that same ssl port.

I think this may be a bug in your code. Could you post a (possibly simplified) version of it that fails in this way?

comment:3 Changed 10 years ago by sjamaan

Also, you may be accidentally reading from or writing to an already closed port. Try the patch in #653 to see if that's happening here.

comment:4 Changed 10 years ago by felix winkelmann

Milestone: 4.8.0

comment:5 Changed 10 years ago by sjamaan

Is this still an issue with the refactorings Thomas made with 1.6.1?

comment:6 Changed 10 years ago by Mario Domenech Goulart

It's been working for me. I have a server that has been up for weeks now. I'm using openssl 1.5.1, though.

comment:7 Changed 9 years ago by Moritz Heidkamp

Resolution: worksforme
Status: newclosed

Unfortunately I'm unable to reproduce this anymore as I don't have the code at hand. Since Mario says it works for him I'm closing this issue for now.

Note: See TracTickets for help on using tickets.