Opened 11 years ago

Closed 11 years ago

#481 closed defect (worksforme)

srfi-19 incorrectly using getenv in experimental branch

Reported by: Alan Post Owned by: klovett@…
Priority: major Milestone:
Component: extensions Version: 4.6.x
Keywords: Cc:
Estimated difficulty:

Description

The srfi-19 egg is not compiling in the experimental branch:

http://pestilenz.org/~ckeen/salmonella-report/2011-01-14/srfi-19.html

The getenv procedure has been deprecated, and should be replaced with get-environment-variable instead.

Change History (3)

comment:1 Changed 11 years ago by felix winkelmann

Milestone: 4.7.0

comment:2 Changed 11 years ago by Alan Post

Taking a closer look at this issue, the problem is in the locale egg, rather than the srfi-19 egg. the locale egg is also Kon's, fortunately.

comment:3 Changed 11 years ago by felix winkelmann

Resolution: worksforme
Status: newclosed

Looks like locale doesn't use this anymore.

Note: See TracTickets for help on using tickets.