Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#426 closed defect (invalid)

s11n deserialize fails sometimes

Reported by: Moritz Heidkamp Owned by:
Priority: major Milestone: 4.9.0
Component: extensions Version: 4.6.x
Keywords: Cc:
Estimated difficulty:

Description

I sometimes get errors like this when deserializing objects:

(deserialize) invalid tag: 88

This even happens with simple objects like serialized strings or symbols. Note that I am exchanging the objects between two different processes, both of which use the same s11n and chicken though. Anything I could try or look for?

Change History (3)

comment:1 Changed 11 years ago by Moritz Heidkamp

Resolution: invalid
Status: newclosed

I think I can take it back, the problem was probably caused by me being dumb and passing a pointer to memory which sometimes got moved by the garbage collector it seems. Sorry for the noise :-)

comment:2 Changed 11 years ago by felix winkelmann

Milestone: 4.7.04.8.0

Milestone 4.7.0 deleted

comment:3 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.