Opened 8 months ago

Closed 8 months ago

#1663 closed defect (invalid)

"make check" fails on mingw-msys on repository search path test

Reported by: sjamaan Owned by:
Priority: major Milestone: 5.2
Component: core libraries Version: 5.1.0
Keywords: Cc:
Estimated difficulty: easy

Description

As reported by wasamasa:

    ======================================== repository search path ...
    (C:/chicken//lib/chicken/11)
    (PASS) (repository-path) contains something by default
     TOTALS:
      1 tests completed in 0.029 seconds
      1 (100.00%) tests passed
      0 (0.00%) tests failed
    "C:/Users/schnev/Downloads/chicken-5.2.0rc1/tests/../chicken 
"sample-module.scm" -output-file "sample-module.c" -dynamic -feature 
chicken-compile-shared -verbose -include-path 
C:/Users/schnev/Downloads/chicken-5.2.0rc1/tests/.. -consult-types-file 
../types.db -ignore-repository -emit-import-library sample-module"
    generating import library `sample-module.import.scm' for module 
`sample-module' ...
    ""gcc" "sample-module.c" -o "sample-module.obj" -c  -fno-strict-aliasing 
-fwrapv -DHAVE_CHICKEN_CONFIG_H -DC_ENABLE_PTABLES -Os -DPIC -DC_SHARED 
-IC:/Users/schnev/Downloads/chicken-5.2.0rc1/tests/.. 
-IC:/chicken//include/chicken"
    rm sample-module.c
    ""gcc" "sample-module.obj" -o "sample-module.so" -Wl,--enable-auto-import 
-shared -LC:/Users/schnev/Downloads/chicken-5.2.0rc1/tests/.. 
-LC:/Users/schnev/Downloads/chicken-5.2.0rc1/tests/.. -lchicken -lm -lws2_32"
    rm sample-module.obj
    (PASS) find-file on #f
    (PASS) find-file on string
    (PASS) find-file on list
    (FAIL) (repository-path) is populated by CHICKEN_REPOSITORY_PATH: expected 
("C:/Users/schnev/Downloads/chicken-5.2.0rc1/tests/.." 
"C:/Users/schnev/Downloads/chicken-5.2.0rc1/tests/test-repository") but got 
("C:\\Users\\schnev\\Downloads\\chicken-5.2.0rc1\\" 
"C:\\Users\\schnev\\Downloads\\chicken-5.2.0rc1\\tests\\test-repository")
    (PASS) setting (repository-path) and loading a library
    (PASS) Putting garbage in (repository-path)
     TOTALS:
      6 tests completed in 0.051 seconds
      5 (83.33%) tests passed
      1 (16.66%) tests failed
    make: *** [check] Error 1

Change History (3)

comment:1 Changed 8 months ago by sjamaan

Tried, but cannot reproduce this

comment:2 Changed 8 months ago by sjamaan

Extra info: might be due to git-shell...

comment:3 Changed 8 months ago by wasamasa

Resolution: invalid
Status: newclosed

I've tried reproducing in a clean environment without git-bash and failed. Might be worth pointing out on the wiki...

Note: See TracTickets for help on using tickets.