Opened 3 months ago

Closed 5 weeks ago

#1461 closed defect (fixed)

file access test fails on windows (wine only? 64bit only?) with PLATFORM=mingw

Reported by: kooda Owned by:
Priority: major Milestone: 5.0
Component: core libraries Version: 5.0
Keywords: Cc:
Estimated difficulty:

Description (last modified by sjamaan)

On Mingw-64:

Error: assertion failed: (file-exists? /)

        Call history:

        <syntax>          (##sys#error "assertion failed" (##core#quote (not (directory-exists? ""))))
        <syntax>          (##core#quote (not (directory-exists? "")))
        <syntax>          (not (directory-exists? ""))
        <syntax>          (directory-exists? "")
        <eval>    (not (directory-exists? ""))
        <eval>    (directory-exists? "")
        <syntax>          (assert (file-exists? /))
        <syntax>          (##core#let ((tmp293 (file-exists? /))) (##core#if (##core#check tmp293) tmp293 (##sys#error "assert...
        <syntax>          (##core#begin (##core#if (##core#check tmp293) tmp293 (##sys#error "assertion failed" (##core#quote ...
        <syntax>          (##core#if (##core#check tmp293) tmp293 (##sys#error "assertion failed" (##core#quote (file-exists? ...
        <syntax>          (##core#check tmp293)
        <syntax>          (##sys#error "assertion failed" (##core#quote (file-exists? /)))
        <syntax>          (##core#quote (file-exists? /))
        <syntax>          (file-exists? /)
        <eval>    (file-exists? /)
        <eval>    (##sys#error "assertion failed" (##core#quote (file-exists? /)))      <--

Change History (6)

comment:1 Changed 7 weeks ago by sjamaan

I can't reproduce this with the standard MingW (with or without MSYS)

comment:2 Changed 7 weeks ago by sjamaan

  • Description modified (diff)

According to Kooda, this happened on Mingw-64, not the "standard" Mingw.

comment:3 Changed 5 weeks ago by sjamaan

  • Summary changed from file access test fails on windows with PLATFORM=mingw to file access test fails on windows (wine? only) with PLATFORM=mingw

According to jjhoo in #chicken, this fails in Wine. I have so far been unable to reproduce this in "real" Windows 7 in a VM, with Mingw-w64 and regular mingw (with and without msys) and msys2.

comment:4 Changed 5 weeks ago by sjamaan

  • Summary changed from file access test fails on windows (wine? only) with PLATFORM=mingw to file access test fails on windows (wine only? 64bit only?) with PLATFORM=mingw

According to jjhoo in #chicken, this also fails in native Windows 10. I've only tested on 32-bit Windows 7 so far (The Windows 10 VM from modern.ie is too large to fit on any of my computers)

comment:5 Changed 5 weeks ago by sjamaan

Correction: jjhoo says it goes OK on native Windows 10. So most likely this is an issue with the Wine DLLs.

comment:6 Changed 5 weeks ago by kooda

  • Resolution set to fixed
  • Status changed from new to closed

Just checked with bare mingw-w64 on windows 10 64bits. It works fine.

It would be nice to check if it works on older windows versions as well, since we theoretically support every version since Vista.

Note: See TracTickets for help on using tickets.