Opened 4 weeks ago

Closed 4 weeks ago

#1460 closed defect (duplicate)

make check does not respect PROGRAM_PREFIX and PROGRAM_SUFFIX

Reported by: kristianlm Owned by:
Priority: major Milestone: 5.0
Component: build system Version: 5.0
Keywords: Cc:
Estimated difficulty: easy

Description

PROGRAM_PREFIX and PROGRAM_SUFFIX are ignored in runtests.sh:

$ make PROGRAM_SUFFIX=5 PLATFORM=linux check
...
cd tests; sh runtests.sh
======================================== version tests ...
runtests.sh: line 67: ../csc: No such file or directory
make: *** [rules.make:967: check] Error 127

Felix is aware of this but I though I'd turn it into an issue for reference.

Change History (2)

comment:1 Changed 4 weeks ago by felix

  • Component changed from unknown to build system
  • Estimated difficulty set to easy
  • Milestone changed from someday to 5.0

comment:2 Changed 4 weeks ago by kooda

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1458

Note: See TracTickets for help on using tickets.