Opened 11 years ago

Closed 9 years ago

Last modified 7 years ago

#13 closed defect (worksforme)

chicken-install fails with TCP connect timeout

Reported by: Ivan Raikov Owned by: felix winkelmann
Priority: critical Milestone: 4.9.0
Component: core tools Version: 4.6.x
Keywords: tcp timeout Cc:
Estimated difficulty:

Description (last modified by Ivan Raikov)

The TCP connect timeout error is back! I cannot install nemo under either Linux or Mac OS X. Any help is appreciated.

/bin/chicken/bin/chicken-install nemo
resolving alias `kitten-technologies' to: http://chicken.kitten-technologies.co.uk/henrietta.cgi
retrieving ...
connecting to host "chicken.kitten-technologies.co.uk", port 80 ...
requesting "/henrietta.cgi?name=nemo&mode=default" ...
reading response ...
TCP connect timeout
resolving alias `call-cc.org' to: http://code.call-cc.org/cgi-bin/henrietta.cgi
connecting to host "code.call-cc.org", port 80 ...
requesting "/cgi-bin/henrietta.cgi?name=nemo&mode=default" ...
reading response ...
TCP connect timeout

Change History (14)

comment:1 Changed 11 years ago by felix winkelmann

Is this system-specific, or does it happen always?

Please try to unapply the commit r14101 and check wether it has any influence.

comment:2 in reply to:  1 ; Changed 11 years ago by Ivan Raikov

The problem occurs on several identically configured Debian Linux systems with slightly different kernel versions, ranging from 2.6.24 to 2.6.26. Patch r14101 seems to have no influence. I have tried both Chicken 4.0.0, which does not include the patch, and 4.0.1, which does, but I get this error in both cases.

Replying to felix:

Is this system-specific, or does it happen always?

Please try to unapply the commit r14101 and check wether it has any influence.

comment:3 in reply to:  2 ; Changed 11 years ago by felix winkelmann

Replying to iraikov:

The problem occurs on several identically configured Debian Linux systems with slightly different kernel versions, ranging from 2.6.24 to 2.6.26. Patch r14101 seems to have no influence. I have tried both Chicken 4.0.0, which does not include the patch, and 4.0.1, which does, but I get this error in both cases.

Replying to felix:

Is this system-specific, or does it happen always?

Please try to unapply the commit r14101 and check wether it has any influence.

If you comment the call to (close-output-port out) out does increasing the TCP timeout help? Is this a particularly slow connection?

comment:4 Changed 11 years ago by felix winkelmann

Version: 4.0.04.0.1

comment:5 in reply to:  3 Changed 11 years ago by Ivan Raikov

Increasing the tcp-read-timeout to 20000 (20 seconds) allows the installation of sxml-transforms to proceed without problems. The connection is indeed somewhat slow.

Replying to felix:

If you comment the call to (close-output-port out) out does increasing the TCP
timeout help? Is this a particularly slow connection?

comment:6 Changed 11 years ago by felix winkelmann

Please try r14397. I increased the read/write timeout to 20 secs and close both in- and output ports together at the end.

If this works you can close the ticket.

comment:7 Changed 11 years ago by Ivan Raikov

Resolution: fixed
Status: newclosed

It seems to be working now.

comment:8 Changed 9 years ago by Ivan Raikov

Description: modified (diff)
Milestone: 4.7.0
Resolution: fixed
Status: closedreopened
Version: 4.0.14.6.x

comment:9 Changed 9 years ago by felix winkelmann

Does increasing the timeout help, or is this caused by something different?

comment:10 in reply to:  9 ; Changed 9 years ago by Ivan Raikov

Yes, increasing the timeout to from 20 to 30 seconds helps with this particular egg. However, shouldn't there be a more robust download procedure that first determines if the egg exists on the particular server, then
tries to fetch it using increasing timeout values?

Replying to felix:

Does increasing the timeout help, or is this caused by something different?

comment:11 in reply to:  10 Changed 9 years ago by felix winkelmann

Replying to iraikov:

Yes, increasing the timeout to from 20 to 30 seconds helps with this particular egg. However, shouldn't there be a more robust download procedure that first determines if the egg exists on the particular server, then
tries to fetch it using increasing timeout values?

To test for the egg being existant, we have to connect, which may timeout. I think there is not much we can do but increase the timeout values or fix your network connection.

I'll increase the timeout to 30 secs, then.

comment:12 Changed 9 years ago by felix winkelmann

Resolution: worksforme
Status: reopenedclosed

I increased the connection and read/write timeouts to 30 secs (merge into "master","experimental" and "prerelease").

comment:13 Changed 8 years ago by felix winkelmann

Milestone: 4.7.04.8.0

Milestone 4.7.0 deleted

comment:14 Changed 7 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.