Opened 6 years ago

Closed 6 years ago

#1082 closed defect (fixed)

A paste that makes pastiche hang

Reported by: Mario Domenech Goulart Owned by:
Priority: major Milestone: someday
Component: unknown Version: 4.8.x
Keywords: pastiche, awful, paste, hang Cc:
Estimated difficulty:

Description

Attached you can find a file (make-check.out) that, when pasted into pastiche, makes it hang when requested.

Steps to reproduce:

  • create a new paste in pastiche with the contents of make-check.out (copy it and paste ot into pastiche's "Your paste" textarea)
  • view the paste created with make-check.out contents

Attachments (1)

make-check.out (221.2 KB) - added by Mario Domenech Goulart 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Mario Domenech Goulart

Attachment: make-check.out added

comment:1 Changed 6 years ago by Christian Kellermann

The problem seems to be html-colorize and the size of the paste. One way would be to ignore colorization in pastiche when pastes get too long.

comment:2 Changed 6 years ago by Christian Kellermann

Rendering the smae amount in csi takes long:

#;2> (time (html-colorize 'scheme (read-all "make-check.out")))
1009.243s CPU time, 597.15s GC time (major), 3020954 mutations, 46948/315725 GCs (major/minor)

comment:3 Changed 6 years ago by Christian Kellermann

Resolution: fixed
Status: newclosed

This as been fixed with the release 0.19/0.20 of pastiche.

Note: See TracTickets for help on using tickets.