Opened 6 years ago

Closed 6 years ago

#1081 closed defect (fixed)

make check error on salmonella-linux-x86 (Testing correct handling of thread-join! with external signals)

Reported by: Mario Domenech Goulart Owned by:
Priority: major Milestone: 4.9.0
Component: unknown Version: 4.8.x
Keywords: make check, threads Cc:
Estimated difficulty:

Description

Happens for both gcc and clang:

../chicken 'srfi-18-signal-test.scm' -output-file 'a.c' -verbose -include-path ..

Warning: clause following `else' clause in `cond': (else (##sys#signal exvar))

Warning: clause following `else' clause in `cond': (else (##sys#signal exvar))
'gcc-4.6' 'a.c' -o 'a.o' -c  -fno-strict-aliasing -fwrapv -DHAVE_CHICKEN_CONFIG_H -DC_ENABLE_PTABLES -g -Wall -Wno-unused -I.. -I"/home/chicken/salmonella-run-publish/chicken/include/chicken"
rm a.c
'gcc-4.6' 'a.o' -o 'a.out' -L.. -L"/home/chicken/salmonella-run-publish/chicken/lib"  -Wl,-R"/home/chicken/salmonella-run-publish/chicken/lib" -lchicken -lm -ldl
rm a.o
Testing correct handling of thread-join! with external signals:
Warning (#<thread: thread0>): in thread: Loop limit exceeded

        Call history:

        srfi-18-signal-test.scm:16: display       
        srfi-18-signal-test.scm:17: thread-sleep!         
        srfi-18-signal-test.scm:18: work-loop     
        srfi-18-signal-test.scm:16: display       
        srfi-18-signal-test.scm:17: thread-sleep!         
        srfi-18-signal-test.scm:18: work-loop     
        srfi-18-signal-test.scm:16: display       
        srfi-18-signal-test.scm:17: thread-sleep!         
        srfi-18-signal-test.scm:18: work-loop     
        srfi-18-signal-test.scm:16: display       
        srfi-18-signal-test.scm:17: thread-sleep!         
        srfi-18-signal-test.scm:18: work-loop     
        srfi-18-signal-test.scm:16: display       
        srfi-18-signal-test.scm:17: thread-sleep!         
        srfi-18-signal-test.scm:18: work-loop     
        srfi-18-signal-test.scm:14: error               <--

Error: uncaught exception: #<condition: (exn)>
.....................................................................................................make[1]: *** [check] Error 70
make[1]: Leaving directory `/home/chicken/salmonella-run-publish/chicken-core'
make: *** [check] Error 2

Change History (1)

comment:1 Changed 6 years ago by Christian Kellermann

Resolution: fixed
Status: newclosed

The cause was an uninitialised interval structure. The fix has been commited in 5d2b4fa

Note: See TracTickets for help on using tickets.