Opened 7 years ago

Closed 7 years ago

#1013 closed defect (fixed)

Trouble installing SRFI-19 with 4.8.0.3

Reported by: xuinkrbin. Owned by:
Priority: major Milestone: someday
Component: unknown Version: 4.8.x
Keywords: Cc:
Estimated difficulty:

Description

Using "sudo chicken-install srfi-19" fails. After some experimentation, I found I needed to run "sudo chicken-install setup-helper" first; yet, I remain stuck. The output I receive can be found at http://pastebin.com/g8YY7FpL. Any assistance would be greatly appreciated.

Change History (8)

comment:1 Changed 7 years ago by xuinkrbin.

Note: I just realized this is marked with "major" priority; I used the default settings when creating the ticket. My apologies if this actually is not "major".

comment:2 Changed 7 years ago by xuinkrbin.

For the record, I seem to be having similar, if not identical problems when attempting to install the "coops" egg.

comment:3 Changed 7 years ago by sjamaan

What kind of operating system/version is this?

comment:4 in reply to:  3 Changed 7 years ago by xuinkrbin.

Replying to sjamaan:

What kind of operating system/version is this?

Mac OS 10.5.

comment:5 Changed 7 years ago by sjamaan

I've tested on NetBSD with a clean setup and I've asked people to test on Mac OS X (10.8), and it works everywhere. Perhaps you can try removing all eggs (chicken-uninstall '*') and reinstalling?

The strange thing is that your paste only shows csc exiting with status 10, but no error message. That should not generally happen. If it still fails after removing all eggs, try manually compiling the file where it fails.

comment:6 Changed 7 years ago by sjamaan

Sorry, chicken exiting with 10 and csc with 256. The exit statuses getting increasingly high is also slightly worrying, I think.

comment:7 Changed 7 years ago by Jim Ursetto

Error 10 could be a bus error in csc. Maybe there are remnants of another installation of Chicken somewhere (I see this one is in /opt, which is probably Macports). I second the motion to try: manually compiling that file using csc -v, and maybe try to see which libraries are being loaded via "DYLD_PRINT_LIBRARIES=1 csc".

The typical root cause for bus error is an egg built with a different version of chicken or a component of an older chicken which is mistakenly found.

comment:8 in reply to:  5 Changed 7 years ago by xuinkrbin.

Resolution: fixed
Status: newclosed

Replying to sjamaan:

I've tested on NetBSD with a clean setup and I've asked people to test on Mac OS X (10.8), and it works everywhere. Perhaps you can try removing all eggs (chicken-uninstall '*') and reinstalling?

The strange thing is that your paste only shows csc exiting with status 10, but no error message. That should not generally happen. If it still fails after removing all eggs, try manually compiling the file where it fails.

Thanks for the idea. What I did was as You suggested, "chicken-uninstall '*'", making sure to grab a list of the installed extensions first. I then ran a script which attempted to reinstall the extensions. As far as I can tell, the only ones which failed are those which are "subsets" of others (e.g., srfi-19-core when I am already installing srfi-19). At this point, and I emphasize that qualifier, I think the issue can be closed.

Note: See TracTickets for help on using tickets.