Opened 9 years ago

Closed 9 years ago

#924 closed defect (duplicate)

Callback test fails on cygwin

Reported by: zmyrgel Owned by:
Priority: major Milestone:
Component: unknown Version: 4.8.x
Keywords: Cc:
Estimated difficulty:

Description

Tried to run make PLATFORM=cygwin PREFIX=pwd all install check but got following failure on callback tests.

---

======================================== callback tests ...
../chicken callback-tests.scm -output-file a.c -verbose -include-path ..
gcc a.c -o a.o -c -fno-strict-aliasing -fwrapv -DHAVE_CHICKEN_CONFIG_H -DC_ENABLE_PTABLES -Os -fomit-frame-pointer -I.. -I"/home/zmyrgel/chicken-4.8.0rc3/include/chicken"
rm a.c
gcc a.o -o a.out -L.. -L"/home/zmyrgel/chicken-4.8.0rc3/lib" -lchicken -lm
rm a.o
callbacks ...
hi!
callbacks ...
hi!
hi!
[panic] callback returned twice - execution terminated

callback-tests.scm:16: print
g67
callback-tests.scm:17: ##sys#gc
callback-tests.scm:17: g11
callback-tests.scm:7: call/cc
callback-tests.scm:9: print
callback-tests.scm:19: command-line-arguments
callback-tests.scm:20: k1
callback-tests.scm:9: print <--
double-return from callback failed as it should.
======================================== runtime tests ...
[panic] nursery is too small - try higher setting using the `-:s' option - execution terminated

rules.make:660: recipe for target `check' failed
make[1]: * [check] Error 1
make[1]: Leaving directory `/home/zmyrgel/chicken-4.8.0rc3'
GNUmakefile:54: recipe for target `check' failed
make:
* [check] Error 2

zmyrgel@gamerig ~/chicken-4.8.0rc3
$

Change History (1)

comment:1 Changed 9 years ago by Mario Domenech Goulart

Resolution: duplicate
Status: newclosed

That's a duplicate of #919 and has been fixed on master.

Note: See TracTickets for help on using tickets.