Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#871 closed defect (fixed)

INTEGER? gives wrong answer on funky floats

Reported by: johnwcowan Owned by:
Priority: major Milestone: 4.9.0
Component: unknown Version: 4.7.x
Keywords: Cc:
Estimated difficulty:

Description

On linux-unix-gnu-x86, version 3.7.5 (rev 61f2799):

(integer? +inf.0) => #t       ; wrong!
(integer? -inf.0) => #t       ; wrong!
(integer? +nan.0) => #f       ; right!

This problem is visible either with or without the numbers egg. There may be a relationship with closed bug #791.

Change History (4)

comment:1 Changed 9 years ago by sjamaan

Which Chicken version? Is this in compiled or interpreted mode, or both?

I can't reproduce this behaviour with the current Chicken master, so I'll need some more information.

comment:2 Changed 9 years ago by sjamaan

oh, sorry about that, you did mention the version. I must've overlooked it. Your tested revision is pretty old and there was a bugfix specifically for C_a_i_integerp made in March.

comment:3 Changed 9 years ago by johnwcowan

Resolution: fixed
Status: newclosed

I did mean 4.7.5. It's fixed in rev 250fa01, so I am closing this.

comment:4 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.