Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#804 closed defect (duplicate)

#i and #e don't work correctly in the numbers egg

Reported by: johnwcowan Owned by:
Priority: major Milestone: 4.9.0
Component: extensions Version: 4.7.x
Keywords: Cc:
Estimated difficulty:

Description

#e1e400 currently returns +inf.0 rather than exact 10400.

#e2.3 currently returns 2.3 rather than 23/10

#i1/2 currently returns 1/2 instead of 0.5

#e+inf.0 currently returns +inf.0 instead of reporting an error

No warnings should be printed.

A reasonable strategy is to look for #i and #e, and failing that, look for . and e. That determines which converter should be used, the exact-arithmetic one or the inexact-arithmetic one. Other than infinities and NaNs?, both converters should accept the same input and do the right thing with it.

Change History (2)

comment:1 Changed 9 years ago by sjamaan

Resolution: duplicate
Status: newclosed

Duplicate of #788 and #734, this bug has been fixed in numbers trunk and requires some extra support which is only available in Chicken 4.7.4 (see #674).

comment:2 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.