Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#680 closed defect (fixed)

chicken HEAD (2011-08-31) breaks sedna

Reported by: Mario Domenech Goulart Owned by: felix winkelmann
Priority: major Milestone: 4.9.0
Component: unknown Version: 4.7.x
Keywords: sedna Cc:
Estimated difficulty:

Description

See http://tests.call-cc.org/master/linux/x86/2011/08/31/salmonella-report/sedna.html

The day before it was not failing (http://tests.call-cc.org/master/linux/x86/2011/08/30/salmonella-report/sedna.html).

It's possible that it is a sedna bug (I haven't checked it). Just in case, I'm opening this ticket.

Change History (5)

comment:1 Changed 10 years ago by Jim Ursetto

Could this be because sedna:extract-string is supposed to return 2 values, but one of the conditional branches returns #f after raising a continuable exception, confusing the flow analysis? Perhaps it should return (values #f #f) or signal a non-continuable exception instead (will the flow analysis understand that?)

comment:2 Changed 10 years ago by felix winkelmann

Owner: set to felix winkelmann
Status: newassigned

comment:3 Changed 10 years ago by felix winkelmann

This was caused by an optimization rule for call-with-values which was incorrectly triggered due to a bug in the scrutinizer.

comment:4 Changed 10 years ago by felix winkelmann

Resolution: fixed
Status: assignedclosed

comment:5 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.