Opened 10 years ago

Closed 10 years ago

#677 closed defect (fixed)

bug in pdf egg

Reported by: felix winkelmann Owned by: Christian Kellermann
Priority: major Milestone:
Component: extensions Version: 4.7.x
Keywords: pdf Cc:
Estimated difficulty:

Description

set-cdr! is called with the wrong number of arguments here:

(define (set-dictionary-value dict name value)
  (set-cdr! (assoc name (dictionary-values dict) value)))

Change History (2)

comment:1 Changed 10 years ago by Christian Kellermann

Owner: set to Christian Kellermann
Status: newaccepted

The root cause seemed to be a misplaced parenthesis pair:

 (define (set-dictionary-value dict name value)
-  (set-cdr! (assoc name (dictionary-values dict) value)))
+  (set-cdr! (assoc name (dictionary-values dict)) value))

I have commited a patch for this to trunk. Who is the maintainer of this egg? Should I tag a new version?

comment:2 Changed 10 years ago by Christian Kellermann

Resolution: fixed
Status: acceptedclosed

Fixed in version 1.0.2

Note: See TracTickets for help on using tickets.