Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#670 closed defect (fixed)

parley does delete output if it is not followed by a newline

Reported by: Christian Kellermann Owned by: Christian Kellermann
Priority: major Milestone: 4.9.0
Component: extensions Version: 4.7.x
Keywords: parley egg terminal #fail Cc: bauerm@…
Estimated difficulty:

Description

With parley the following happens in csi:

#;1> (display "hi")
#;2> 

whereas this works:

#;2> (display "hi")(newline)
hi
#;4> 

My guess is that, since parley deletes everything on the current line to draw its output the output simply gets overwritten/deleted.

Thanks to Matthias Bauer for the report.

Change History (3)

comment:1 Changed 10 years ago by Christian Kellermann

Cc: bauerm@… added
Status: newaccepted

Hi,

I have committed a patch to trunk to fix this issue, please let me know whether this works as it also has an effect of the signature to external handler procedures.

Thanks,

Christian

comment:2 Changed 10 years ago by Christian Kellermann

Resolution: fixed
Status: acceptedclosed

confirmed as working by Matthias, thanks for the report!
This will get included in the next release

comment:3 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.