Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#650 closed defect (fixed)

convert profiler time-accumulation code to using flonum operations

Reported by: felix winkelmann Owned by: felix winkelmann
Priority: major Milestone: 4.9.0
Component: core libraries Version: 4.7.x
Keywords: profiler Cc:
Estimated difficulty:

Description

Sven Hartrumpf reported incorrect numbers for long-running tests. This is possibly caused by fixnum overflows, either in the code that converts CPU time to milliseconds or where invocation-times are added up.

Change History (2)

comment:1 Changed 10 years ago by felix winkelmann

Resolution: fixed
Status: newclosed

Seems to work now, according to Sven.

comment:2 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.