Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#622 closed defect (fixed)

Bindings from the current environment leak into scheme-report-environment

Reported by: pdh Owned by: felix winkelmann
Priority: major Milestone: 4.9.0
Component: core libraries Version: 4.7.x
Keywords: Cc:
Estimated difficulty:

Description (last modified by felix winkelmann)

The "numbers" egg breaks (scheme-report-environment).

This is what it looks like:

$ csi
Version 4.7.0
openbsd-unix-gnu-x86-64 [ 64bit manyargs dload ptables ]
...
#;1> (eval '(- 3 1) (scheme-report-environment 5))
2
#;2> ((eval '- (scheme-report-environment 5)) 4 2)
2
#;3> (use numbers)
...
#;4> (eval '(- 3 1) (scheme-report-environment 5))

Error: unbound variable: numbers#-

Call history:

<syntax> (eval (quote (- 3 1)) (scheme-report-environment 5))
<syntax> (quote (- 3 1))
<syntax> (##core#quote (- 3 1))
<syntax> (scheme-report-environment 5)
<eval> (eval (quote (- 3 1)) (scheme-report-environment 5))
<eval> (scheme-report-environment 5)
<syntax> (- 3 1)
<eval> (- 3 1) <--

#;4> ((eval '- (scheme-report-environment 5)) 4 2)

Error: unbound variable: numbers#-

Call history:

<syntax> ((eval (quote -) (scheme-report-environment 5)) 4 2)
<syntax> (eval (quote -) (scheme-report-environment 5))
<syntax> (quote -)
<syntax> (##core#quote -)
<syntax> (scheme-report-environment 5)
<eval> ((eval (quote -) (scheme-report-environment 5)) 4 2)
<eval> (eval (quote -) (scheme-report-environment 5))
<eval> (scheme-report-environment 5) <--

#;4>

Observed in the "numbers" egg Version 2.6. (That is, the version
that I installed today.)
r

Change History (6)

comment:1 Changed 10 years ago by sjamaan

Component: extensionsexpander
Owner: set to sjamaan
Status: newaccepted

The bug is in Chicken, not numbers:

(module foo (+) (import (except scheme +)) (define (+ . _) 'plus))
(import foo)
(eval '(+ 1 2) (scheme-report-environment 5))

I'll look into it.

comment:2 Changed 10 years ago by sjamaan

Summary: "numbers" egg breaks scheme-report-environmentBindings from the current environment leak into scheme-report-environment

comment:3 Changed 10 years ago by felix winkelmann

Owner: changed from sjamaan to felix winkelmann
Status: acceptedassigned

comment:4 Changed 10 years ago by felix winkelmann

Component: expandercore libraries
Description: modified (diff)

I think this may be an environment-related problem. Since I've changed this now, I'll take a look myself.

comment:5 Changed 10 years ago by felix winkelmann

Resolution: fixed
Status: assignedclosed

I can't reproduce this anymore. Recent changes to the implementation of eval-environments seem tto have fixed this.

comment:6 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.