Opened 10 years ago

Closed 8 years ago

Last modified 7 years ago

#603 closed defect (wontfix)

yelp's test script is broken

Reported by: Mario Domenech Goulart Owned by: ddp
Priority: major Milestone:
Component: extensions Version: 4.7.x
Keywords: yelp Cc:
Estimated difficulty:

Change History (6)

comment:1 Changed 10 years ago by ddp

Status: newassigned

Yes and no. The issue is that the Yelp API requires a developer key. For the obvious reason, I don't want to check mine in, so I wrote the test script such that if you go and get one and put it in a magically named file in the right place all will work. Not particularly useful for regression testing I realize, but better than not checking in the test script at all, methinks. Maybe I should go see if I can get another API key out of Yelp.

comment:2 Changed 10 years ago by felix winkelmann

Milestone: 4.8.0

comment:3 Changed 9 years ago by ddp

I asked Yelp for an additional API key. If they give me one (and assuming it's a v1 API YWSID), I'll check it into the test script. Otherwise I'm going to close this ticket because nothing's really broken. A while back I added additional comments about what's going on in the test script and in the Wiki entry for the egg. Everyone using this egg needs their own private YWSID key from Yelp. See http://www.yelp.com/developers for more information.

comment:4 Changed 8 years ago by ddp

Resolution: wontfix
Status: assignedclosed

comment:5 Changed 8 years ago by ddp

I never heard back from Yelp.

comment:6 Changed 7 years ago by ddp

I updated tests/run.scm to only run if it can find a '../../ywsid.scm' file in the local root. This effectively nukes the tests for everyone else but it should fix the nightly salmonella in the trunk (and preserves my ability to run the tests).

Note: See TracTickets for help on using tickets.