Opened 6 years ago

Closed 5 months ago

#1520 closed defect (fixed)

binary-search: test failure: (=) bad argument type - not a number: #f

Reported by: Mario Domenech Goulart Owned by:
Priority: major Milestone: 5.4
Component: extensions Version: 5.0.0
Keywords: binary-search Cc:
Estimated difficulty:

Change History (6)

comment:2 Changed 8 months ago by felix winkelmann

Milestone: someday5.4

comment:4 Changed 6 months ago by sjamaan

Resolution: fixed
Status: closedreopened

comment:5 Changed 6 months ago by sjamaan

I think the problem is that (square x) returns bignums on 32-bit platforms, while binary-search assumes fixnums everywhere.

The code checks that the sequence is within fixnum range, but it doesn't do so for the return value of proc in the loop (but still calls fixnum ops on it!)

comment:6 Changed 5 months ago by Mario Domenech Goulart

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.