Opened 5 years ago

Closed 5 years ago

#1386 closed defect (fixed)

file-read-access? returns #f for non-existent files

Reported by: Vasilij Schneidermann Owned by:
Priority: minor Milestone: 5.0
Component: core libraries Version: 4.12.0
Keywords: posix Cc:
Estimated difficulty: easy

Description

As seen on IRC:

<Seylerius> Hrm. Isn't file-read-access? supposed to error out on a nonexistent file?

Expected outcome:

(file-read-access? "/con/con") ;=> <file error>

Actual outcome:

(file-read-access? "/con/con") ;=> #f

I've worked out a patch with the help of TheLemonMan? on IRC.

Attachments (2)

0001-Handle-other-errors-than-EACCES-for-access-3.patch (1.2 KB) - added by Vasilij Schneidermann 5 years ago.
0001-Handle-other-errors-than-EACCES-for-access-3.2.patch (1.2 KB) - added by Vasilij Schneidermann 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Vasilij Schneidermann

comment:1 Changed 5 years ago by felix winkelmann

The patch and the intended behaviour looks correct. But this would be a Change Request, I suppose.

comment:2 Changed 5 years ago by Vasilij Schneidermann

Milestone: someday5.0

I've changed my mind and reworked the patch for C5.

Changed 5 years ago by Vasilij Schneidermann

comment:3 Changed 5 years ago by sjamaan

Resolution: fixed
Status: newclosed

Fixed by 536e2351cf5836e76df79395813501fcb2c4b034

Note: See TracTickets for help on using tickets.