Opened 6 years ago

Closed 5 years ago

#1181 closed defect (fixed)

memory corruption when user-interrupts and tcp

Reported by: kristianlm Owned by:
Priority: major Milestone: 4.11.0
Component: unknown Version: 4.9.x
Keywords: Cc:
Estimated difficulty:

Description

It seems user interrupts from csi, when reading from tcp ports causes memory corruption. As shown in this paste: http://paste.call-cc.org/paste?id=ae7e3a52e4a71cf9c1c6697234d168a343022309

~$ csi -n

CHICKEN
(c) 2008-2014, The CHICKEN Team
(c) 2000-2007, Felix L. Winkelmann
Version 4.9.1 (rev 6a860ab)
linux-unix-gnu-x86-64 [ 64bit manyargs dload ptables ]
compiled 2014-09-30 on devpool08 (Linux)

#;1> (use tcp)
; loading /home/ckellerm/chickens/master/lib/chicken/7/tcp.import.so ...
; loading library tcp ...
#;2> (define-values (i o) (tcp-connect "127.0.0.1" 1234))
#;3> (read-char i)
^C
*** user interrupt ***
#;3> ^[[A

Error: unbound variable: 
3>  (read-char i)                                        
^C
*** user interrupt ***
#;3>  (read-char i)
^C
*** user interrupt ***
#;3> ^C
*** user interrupt ***
#;3>  (read-char i)
^C
*** user interrupt ***
#;3>  (read-char i)
^C
*** user interrupt ***
#;3>  (read-char i)
*** Error in `csi': realloc(): invalid next size: 0x0000000001f5beb0 ***
Aborted

I am reproducing this on Linux 3.18.6.

Change History (2)

comment:1 Changed 5 years ago by sjamaan

Milestone: someday4.11.0

There's a patch for fixing the scheduler, which needs some more attention

comment:2 Changed 5 years ago by sjamaan

Resolution: fixed
Status: newclosed

I can no longer reproduce this bug. It looks like this was fixed at the ICC with 4e32262036806b2fc51964e518135fcd3de3a79b

Note: See TracTickets for help on using tickets.