Opened 8 years ago

Closed 8 years ago

#955 closed defect (fixed)

message-digest's test failure on 2012-12-05

Reported by: Mario Domenech Goulart Owned by: Kon Lovett
Priority: major Milestone: someday
Component: extensions Version: 4.8.x
Keywords: message-digest Cc:
Estimated difficulty:

Description

See http://tests.call-cc.org/master/linux/x86/2012/12/05/salmonella-report/test/message-digest.html

message-digest has not changed recently, and no egg it depends on has changed either.

The chicken used by salmonella on 2012-12-04 (all message-digest's tests pass) was 432aa3c. The chicken used on 2012-12-05, when message-digest's tests fail, was 19a6b5b.

Maybe chicken core's 52c69531d586a39c51f3acc636596c65e181622e is the cause?

Change History (5)

comment:1 Changed 8 years ago by Kon Lovett

Status: newaccepted

Cannot reproduce w/ chicken core 52c69531d586a39c51f3acc636596c65e181622e but I will look deeper. (MacOS 10.8.2 w/ clang 4.1 & x86_64)

comment:2 Changed 8 years ago by Kon Lovett

(foreign-lambda* (... (unsigned-integer64 u64) ...)

=>

C_u64 u64=(C_u64 )C_num_to_uint64(C_a1);

segmentation fault from the above C.

comment:3 in reply to:  2 Changed 8 years ago by felix winkelmann

Replying to kon:

(foreign-lambda* (... (unsigned-integer64 u64) ...)

=>

C_u64 u64=(C_u64 )C_num_to_uint64(C_a1);

segmentation fault from the above C.

This could only happen in case C_al does not hold a fixnum or flonum.

comment:4 Changed 8 years ago by Kon Lovett

Hum:(test-assert (message-digest-update-u64-be md #xAB54A98CEB1F0AD2))

comment:5 Changed 8 years ago by sjamaan

Resolution: fixed
Status: acceptedclosed

Fixed by 42c869949f893baba40c9b0d5e4832eb2004b20e

Note: See TracTickets for help on using tickets.