Opened 8 years ago

Closed 7 years ago

#925 closed defect (fixed)

Tests for smtp and internet-message eggs start breaking on 2012-09-19

Reported by: Mario Domenech Goulart Owned by:
Priority: major Milestone: someday
Component: unknown Version: 4.8.x
Keywords: Cc: Ivan Raikov
Estimated difficulty:

Description

See http://tests.call-cc.org/master/linux/x86/2012/09/19/yesterday-diff/log2/test/smtp.html and http://tests.call-cc.org/master/linux/x86/2012/09/19/yesterday-diff/log2/test/internet-message.html for the full error messages.

Both tests show a similar error message:

Error: (map) bad argument type - not a list: #<char-set>

None of those eggs were modified at the period the errors occur. The core changes were 0f6cef9..8d409f9. The core changes correspond to irregex update patches, but the eggs don't use the irregex unit, as far as I can see.

Change History (2)

comment:1 Changed 8 years ago by Ivan Raikov

Thanks for reporting, but this is not caused by changes in core. I have made some changes in the abnf egg, but have not yet updated smtp and internet-message (and mbox, which should also be affected), so this is why these errors occur. I will make new releases of these eggs soon.

comment:2 Changed 7 years ago by sjamaan

Resolution: fixed
Status: newclosed

Looks like this has been fixed (a long time ago, even?), so I'm closing this ticket.

Note: See TracTickets for help on using tickets.