Opened 9 years ago

Closed 9 years ago

#923 closed defect (fixed)

Make check fails on OpenBSD 5.1 with 4.8.0rc3

Reported by: zmyrgel Owned by:
Priority: minor Milestone: 4.9.0
Component: build system Version: 4.8.x
Keywords: openbsd Cc:
Estimated difficulty:

Description

Make check fails on scrutiny test and exits with exit code 2.

Attachments (1)

chicken.output (37.7 KB) - added by zmyrgel 9 years ago.
Output of gmake PLATFORM=bsd PREFIX=/home/zmyrgel/tmp install check

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by zmyrgel

Attachment: chicken.output added

Output of gmake PLATFORM=bsd PREFIX=/home/zmyrgel/tmp install check

comment:1 Changed 9 years ago by felix winkelmann

Keywords: openbsd added
Milestone: 4.8.0
Priority: majorminor

This is caused by the warnings that are emitted by OpenBSD's `gcc' variant. The stderr output of the scrutinizer tests is compared with a pre-generated file - the gcc warnings get in the way there.

This needs to be handled in the test-script.

comment:2 Changed 9 years ago by Ivan Raikov

Milestone: 4.9.0

comment:3 Changed 9 years ago by sjamaan

Resolution: fixed
Status: newclosed

Fixed by 0e68a6d2ff664fbedfd47b0553c59e97ea86f928

Note: See TracTickets for help on using tickets.