Opened 8 years ago

Closed 6 years ago

#854 closed defect (fixed)

Sometimes additional import libraries are exported when using the -j switch

Reported by: sjamaan Owned by: felix winkelmann
Priority: minor Milestone: 4.9.0
Component: compiler Version: 4.7.x
Keywords: Cc:
Estimated difficulty:

Description

This can be seen with the prometheus egg.

Just run csc -s -j hermes hermes.scm and you'll see it will have written both hermes.import.scm and _hermes.import.scm; the latter wasn't requested, and this in fact clobbers the custom hand-crafted import file with a generic one, which breaks the egg.

As a workaround, the import libraries are now shipped with the egg instead of emitting them every time the libraries are compiled.

Change History (1)

comment:1 Changed 6 years ago by sjamaan

Resolution: fixed
Status: newclosed

This is so silly: after all this time, it turns out that the bug was just an unexpected behaviour of s48-modules itself: it contained a strange hack to force the compiler to emit import libraries for the _-prefixed modules!

Since the user can request this him- or herself, and is told to do so in the egg's manual, I think removing this behaviour is the best solution. This is done with the change in [29502].

Note: See TracTickets for help on using tickets.