Opened 10 years ago

Closed 10 years ago

#840 closed defect (wontfix)

stalin: Various type errors

Reported by: sjamaan Owned by: felix winkelmann
Priority: minor Milestone:
Component: extensions Version: 4.7.x
Keywords: Cc:
Estimated difficulty:

Description

Mario's specialization run of Salmonella found a few problems with Stalin: http://parenteses.org/mario/misc/specialize-report/install/stalin.html

The biggest problem is the call to abort with no arguments; I guess it needs (define abort exit) or something like that for compatibility? The other ones look like there's just some difference between procedures in Stalin's standard library and those in Chicken's.

Change History (1)

comment:1 Changed 10 years ago by felix winkelmann

Resolution: wontfix
Status: newclosed

I do not maintain stalin - this egg should be merely seen as an interesting curiosity or for experimentation (stalin itself seems to be buggy in its handling of closures, which I could reproduce with the official stalin distribution). So, I'm not inclined to work much on this. The call to abort indeed conflicts with the one provided by the CHICKEN library, but in this particular case it is not critical.

Note: See TracTickets for help on using tickets.