Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#796 closed defect (fixed)

If there is a page called "foo", then trying to create a page called "foo/bar" emits an unfriendly 500 error page

Reported by: Alaric Snell-Pym Owned by: sjamaan
Priority: minor Milestone: 4.9.0
Component: wiki Version: 4.7.x
Keywords: Cc:
Estimated difficulty:

Description

I tried to create a new page (events/chicken-uk-2012), thereby inaugurating the new "events" directory, but got a 500 error when attempting to actually save the new page.

Apparently this used to work, with missing path components being automatically generated...

Change History (4)

comment:1 Changed 8 years ago by Alaric Snell-Pym

Summary: Can't create wiki pages with not-already-existing directories in the pathIf there is a page called "foo", then trying to create a page called "foo/bar" emits an unfriendly 500 error page

Turns out that's a lie; the problem is that there was already a page called "events".

So I'm now changing this ticket to be one about nasty error messages :-)

Ideally, in this case, there should be an error message stating that you can't create subpages of a page; directory names and page names must be distinct.

comment:2 Changed 8 years ago by sjamaan

Owner: set to sjamaan
Status: newaccepted

comment:3 Changed 8 years ago by sjamaan

Resolution: fixed
Status: acceptedclosed

This is now implemented simply by redirecting the user to the higher path which is a file when that's the case. If there are no new bugs we run into I will tag a new qwiki release soon.

comment:4 Changed 7 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.