Opened 8 years ago

Closed 4 years ago

#745 closed defect (fixed)

disable specialization for assigned toplevel variables

Reported by: felix winkelmann Owned by: felix winkelmann
Priority: minor Milestone:
Component: compiler Version: 4.7.x
Keywords: specialization Cc:
Estimated difficulty:

Description

Redefinition of assigned variables should disable specialization for those functions. This is not as simple as it sounds, since it would disable all specialization in the core system. It means we need a special build-mode or feature-ID to prevent non-specialization when compiling the core system.

Change History (5)

comment:1 Changed 4 years ago by sjamaan

Aren't assigned toplevel variables already disabled from specialization?

At least, #1219 seems to suggest exactly the disabling of specializations in core that you warn about here.

comment:2 Changed 4 years ago by felix winkelmann

Resolution: fixed
Status: newclosed

Yes, I think this ticket is obsolete.

comment:3 Changed 4 years ago by sjamaan

Resolution: fixed
Status: closedreopened

It turns out that #1219 is caused by a separate bug

comment:4 Changed 4 years ago by sjamaan

I think this is not necessary anymore with CHICKEN 5, where everything will be properly namespaced.

comment:5 Changed 4 years ago by sjamaan

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.