Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#63 closed defect (fixed)

create-directory with parents doesn't accept relative paths under Unix

Reported by: sjamaan Owned by:
Priority: major Milestone:
Component: core libraries Version: 4.1.x
Keywords: posix Cc:
Estimated difficulty:

Description

(create-directory "./foo" #t) => Error: (create-directory) cannot create directory - Permission denied: "/./foo"

The posixwin.scm implementation looks like it should work. The Unix implementation should be changed to match it. See the attached patch.

It'd be good to write a regression test for this, but I'm not sure how to do that cleanly (without leaving too much crap around in the FS).

Attachments (1)

posixunix.scm.patch (650 bytes) - added by sjamaan 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by sjamaan

Attachment: posixunix.scm.patch added

comment:1 Changed 10 years ago by felix winkelmann

Resolution: fixed
Status: newclosed

Should be fixed in r15734 (by Kon). I haven't tested it myself, yet.

comment:2 Changed 10 years ago by (none)

Milestone: 4.2.0

Milestone 4.2.0 deleted

Note: See TracTickets for help on using tickets.