Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#471 closed defect (fixed)

message-digest tests fail

Reported by: ckeen Owned by: kon
Priority: major Milestone: 4.9.0
Component: extensions Version: 4.6.x
Keywords: Cc:
Estimated difficulty:

Description

The first one does fail with older chickens as well (and the tagged releases):

-- testing Message Digest u32-be Source --------------------------------------
(message-digest-update-u32-be md 2729624274.0) ....................... [ERROR]
    
Error: bad argument type - not an integer: 2729624274.0
(finalize-message-digest md) ......................................... [ FAIL]
    expected "a2b2c2d200" but got "0000000000"
2 tests completed in 0.007 seconds.
1 failure (50.0%).
1 error (50.0%).
0 out of 2 (0%) tests passed.
-- done testing Message Digest u32-be Source ---------------------------------

From my understanding the input is too large for a fixnum. Did this ever work?

This one passes on older chickens but with a git experimental it fails:

-- testing Message Digest Make (DEPRECATED) ----------------------------------
(make-binary-message-digest simple-src make-context digest-leng... ... [ERROR]
    
Error: unbound variable: make-context
    (make-binary-message-digest
      simple-src
      make-context
      digest-length
      init
      update
      final)
(make-message-digest simple-src make-context digest-length init... ... [ERROR]
    
Error: unbound variable: make-context
2 tests completed in 0.002 seconds.
2 errors (100%).
0 out of 2 (0%) tests passed.
-- done testing Message Digest Make (DEPRECATED) -----------------------------

Hope this helps...

Christian

Change History (5)

comment:1 Changed 7 years ago by ckeen

This is still valid for 4.6.0 and 4.6.4

comment:2 Changed 7 years ago by kon

... From my understanding the input is too large for a fixnum. Did this ever work? ...

I remember no errors. The problem is because the foreign type `integer64' is not accepting the flonum-integer.

... This one passes on older chickens but with a git experimental it fails: ...

It should have failed in every Chicken release. (Fixed.)

comment:3 Changed 7 years ago by kon

  • Resolution set to fixed
  • Status changed from new to closed

I am closing this for now as "fixed" even though values larger than fixnum are still not accepted. I will just make a note in doc.

comment:4 Changed 6 years ago by felix

  • Milestone changed from 4.7.0 to 4.8.0

Milestone 4.7.0 deleted

comment:5 Changed 5 years ago by felix

  • Milestone changed from 4.8.0 to 4.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.