Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#376 closed defect (worksforme)

chicken-install panic on Windows/cygwin: nursery is too small

Reported by: Mario Domenech Goulart Owned by: felix winkelmann
Priority: major Milestone: 4.9.0
Component: core tools Version: 4.6.x
Keywords: chicken-install cygwin nursery Cc:
Estimated difficulty:

Description

$ /home/mario/local/master/bin/chicken-install.exe
[panic] nursery is too small - try higher setting using the `-:s' option - execution terminated

I could reproduce this behavior with chicken from both master and make-refactoring branches.

Change History (10)

comment:1 Changed 11 years ago by Mario Domenech Goulart

Setting a higher value for -:s (like -:s1000000) doesn't help, BTW.

comment:2 Changed 11 years ago by felix winkelmann

Owner: set to felix winkelmann
Status: newassigned

What's the output of chicken-install -:d ?

comment:3 Changed 11 years ago by felix winkelmann

Milestone: 4.7.04.6.0

comment:4 Changed 11 years ago by Mario Domenech Goulart

Here's the output of chicken-install -:d

[debug] application startup...
[debug] heap resized to 500000 bytes
[debug] stack bottom is 0x22cd10.
[debug] entering toplevel toplevel...
[debug] stack resized to 131072 bytes
[debug] entering toplevel library_toplevel...
[debug] entering toplevel eval_toplevel...
[debug] entering toplevel expand_toplevel...
[debug] entering toplevel srfi_1_toplevel...
[debug] entering toplevel posix_toplevel...
[debug] entering toplevel scheduler_toplevel...
[debug] entering toplevel regex_toplevel...
[debug] entering toplevel extras_toplevel...
[debug] entering toplevel data_structures_toplevel...
[debug] entering toplevel ports_toplevel...
[debug] entering toplevel utils_toplevel...
[debug] entering toplevel srfi_13_toplevel...
[debug] entering toplevel srfi_14_toplevel...
[debug] entering toplevel files_toplevel...
[debug] entering toplevel chicken_syntax_toplevel...
; loading /home/mario/local/master/lib/chicken/5/setup-download.so ...
[debug] loading compiled module `/home/mario/local/master/lib/chicken/5/setup-download.so' (handle is 0x6ba80000)
[debug] entering toplevel toplevel...
[debug] entering toplevel tcp_toplevel...
; loading /home/mario/local/master/lib/chicken/5/setup-api.so ...
[debug] loading compiled module `/home/mario/local/master/lib/chicken/5/setup-api.so' (handle is 0x67680000)
[debug] entering toplevel toplevel...
; loading library chicken-ffi-syntax ...
[debug] loading compiled module `cygchicken-0.dll' (handle is 0x18bd0000)
[panic] nursery is too small - try higher setting using the `-:s' option - execution terminated

comment:5 Changed 11 years ago by felix winkelmann

This is very strange: I got the same error and was unable to figure out what's wrong. After rebuilding with a new chicken (I built from the 4.5.0 tarball and then rebuilt chickan again - the compiler seems to work, only chicken-install doesn't) the problem went away. That is, I assume it is somehow related to the rebuild.

Somehow the load-library call (which does a dlopen(3)) failed when chicken-install tried to load the core library chicken-ffi-syntax. I can not say why it failed.

I pushed a few changes (master). Can you try again? Can you also try to just build/install and then rebuild with the installed chicken executable (touch *.scm first). Perhaps there is an incompatibility with code produced by older chickens.

comment:6 Changed 11 years ago by Mario Domenech Goulart

Indeed. Building it with 4.6.0rc1 makes chicken-install work. I could install and (use) amb as a test.

comment:7 Changed 11 years ago by felix winkelmann

Milestone: 4.6.04.7.0

comment:8 Changed 11 years ago by felix winkelmann

Resolution: worksforme
Status: assignedclosed

I close this now. If you think this should be kept open for closer scrutiny, then please reopen. Apparently there is some symbol-resolution problem, caused by old .c files in the distribution (or .c files generated by an old chicken).

comment:9 Changed 11 years ago by felix winkelmann

Milestone: 4.7.04.8.0

Milestone 4.7.0 deleted

comment:10 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.