Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#374 closed defect (invalid)

make spotless doesn't remove cygchicken-0.dll and libchicken.dll.a

Reported by: Mario Domenech Goulart Owned by: felix winkelmann
Priority: minor Milestone: 4.9.0
Component: build system Version: 4.6.x
Keywords: windows cygwin make spotless Cc:
Estimated difficulty:

Description

On Windows/cygwin, make spotless doesn't remove cygchicken-0.dll and libchicken.dll.a (master branch).

Change History (8)

comment:1 Changed 10 years ago by felix winkelmann

Owner: set to felix winkelmann
Status: newassigned

comment:2 Changed 10 years ago by felix winkelmann

I can not reproduce this. How have you invoked make?

comment:3 Changed 10 years ago by Mario Domenech Goulart

Resolution: invalid
Status: assignedclosed

Damn, now I can't reproduce it either.

I don't remember what the make invocation was actually. It was a combination of PLATFORM=cygwin, PREFIX=/home/mario/local/master, CHICKEN=/home/mario/local/chicken-4.4.6, CHICKEN=/home/mario/local/make-refactoring and DEBUGBUILD=1 (or without it). I tried some of them again and could not reproduce the problem.

Sorry for the noise. I'm closing this ticket as invalid.

comment:4 Changed 10 years ago by felix winkelmann

I think you forgot to pass "PLATFORM=cygwin" while issuing "make spotless".

comment:5 Changed 10 years ago by Mario Domenech Goulart

I don't think so. make doesn't run if I don't provide PLATFORM.

comment:6 Changed 10 years ago by Mario Domenech Goulart

I mean, it runs but tells me to provide a valid value for PLATFORM.

comment:7 Changed 9 years ago by felix winkelmann

Milestone: 4.7.04.8.0

Milestone 4.7.0 deleted

comment:8 Changed 8 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.