Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#365 closed defect (fixed)

colorize variable messup

Reported by: sjamaan Owned by: sjamaan
Priority: major Milestone: 4.9.0
Component: wiki Version: 4.6.x
Keywords: span eggs bacon and span Cc: Jim Ursetto
Estimated difficulty:

Description

|06:19| ( zbigniew) #;2> (html-colorize 'scheme "(foo")
|06:19| ( zbigniew) "<span class=\"paren2\">(<span class=\"default\">foo</span></span></span></span>"
|06:19| ( zbigniew) #;3> (html-colorize 'scheme "(foo")
|06:19| ( zbigniew) "<span class=\"paren3\">(<span class=\"default\">foo</span></span></span></span></span></span>"
|06:19| ( zbigniew) #;4> (html-colorize 'scheme "(foo")
|06:19| ( zbigniew) "<span class=\"paren4\">(<span class=\"default\">foo</span></span></span></span></span></span></span></span>"
|06:19| ( zbigniew) ...
|06:19| ( zbigniew) #;11> (html-colorize 'scheme "(foo")
|06:19| ( zbigniew) "<span class=\"paren5\">(<span
class=\"default\">foo</span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span>"

It looks like this is caused by the big LET around the coloring type definition in define-coloring-type*. It shouldn't be a static variable but one per usage of the coloring type (or reset each when a new string is parsed)

Change History (3)

comment:1 Changed 11 years ago by sjamaan

Resolution: fixed
Status: newclosed

Wrapped it in a lambda :)

comment:2 Changed 11 years ago by felix winkelmann

Milestone: 4.7.04.8.0

Milestone 4.7.0 deleted

comment:3 Changed 9 years ago by felix winkelmann

Milestone: 4.8.04.9.0

Milestone 4.8.0 deleted

Note: See TracTickets for help on using tickets.