Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#332 closed defect (fixed)

chicken-install throws an internal error in HEAD

Reported by: Jim Ursetto Owned by: felix winkelmann
Priority: critical Milestone:
Component: core libraries Version: 4.5.x
Keywords: Cc:
Estimated difficulty:

Description

Hello esteemed team leader.

I am having a reproducible error pulling down the sql-de-lite egg from either mirror, which I have tracked down to commit 7bd92ff78681ddee949441114bcc8bd6bd6a4284.
The symptom is below:

$ chicken-install -n -l http://code.call-cc.org/cgi-bin/henrietta.cgi sql-de-lite
retrieving ...
connecting to host "code.call-cc.org", port 80 ...
requesting "/cgi-bin/henrietta.cgi?name=sql-de-lite&mode=default" ...
reading response ...
HTTP/1.1 200 OK
Date: Thu, 12 Aug 2010 04:04:47 GMT
Server: Apache/2.2.9 (Debian) DAV/2 SVN/1.5.1 mod_ssl/2.2.9 OpenSSL/0.9.8g
Connection: close
Vary: Accept-Encoding
Transfer-Encoding: chunked
Content-Type: text/plain
reading chunks ...

[pause of about 6 seconds]

Error: (=) bad argument type - not a number: #f

Something in that commit 7bd92ff78 is causing the error; the parent commit works. I have to assume it is an interaction between TCP and the new flonum milliseconds stuff. I am using experimental HEAD (c6d6f125c1eed52dd9e8540fc4454eea95472b09) which still has this issue. Some other eggs I've tried seem to work, so perhaps this is because sql-de-lite is transferring 4MB.

Unfortunately I haven't tracked down the exact cause yet, but hopefully this will help.

Change History (2)

comment:1 in reply to:  description Changed 11 years ago by felix winkelmann

Resolution: fixed
Status: newclosed

Replying to zbigniew:

Hello esteemed team leader.

Very funny.

I am having a reproducible error pulling down the sql-de-lite egg from either mirror, which I have tracked down to commit 7bd92ff78681ddee949441114bcc8bd6bd6a4284.

Thanks, it should be fixed in experimental f9c40d5.

comment:2 Changed 11 years ago by felix winkelmann

Milestone: 4.6.0

Milestone 4.6.0 deleted

Note: See TracTickets for help on using tickets.