Opened 10 years ago

Closed 10 years ago

#284 closed task (fixed)

figure out a way to make the 0xab branch of the qt egg available

Reported by: felix winkelmann Owned by: felix winkelmann
Priority: minor Milestone:
Component: extensions Version: 4.5.x
Keywords: qt 0xab Cc:
Estimated difficulty:

Description

The branch contains a lot of cool functionality, but uses (AFAIK) undocumented features. It would be nice if we could find a not too ugly and confusing way to provide that functionality without removing the relatively straightforward and functioning current version.

Change History (6)

comment:1 Changed 10 years ago by felix winkelmann

Owner: set to felix winkelmann
Status: newassigned

After discussing this on #chicken, here is the plan:

  • rename the current qt egg to qt-light
  • release the 0xab branch as the new qt egg, and provide documentation for the extra functionality (as if I didn't have better things to do!)

comment:2 in reply to:  1 Changed 10 years ago by Mario Domenech Goulart

Replying to felix:

After discussing this on #chicken, here is the plan:

  • rename the current qt egg to qt-light
  • release the 0xab branch as the new qt egg, and provide documentation for the extra functionality (as if I didn't have better things to do!)

I think you should leave the documentation for the new qt egg to 0xab. Just copy the old docs for qt to qt-light and maybe add a note to the new qt egg page (0xab's) indicating that things have changed and the old qt egg is now qt-light.

comment:3 Changed 10 years ago by Mario Domenech Goulart

Actually it'd be nice to know if 0xab's code isn't another egg like those which are checked in once and never touched again...

I'm afraid that if we rename qt to qt-light and in some months the new qt gets unmaintained, nobody will use it, so the canonical egg for qt will be qt-light (it's a hypothesis -- I don't mean any demerit to 0axb's work). Then the existence of an egg named qt (now unmaintained) will just make things confusing.

Now, thinking more clearly about this, maybe it'd be better to give 0xab's egg a new name (qt-0xab, qt-ng, qt-plus, cuter ...).

Sorry for contributing to the entropy. And feel free to ignore this comment.

comment:4 Changed 10 years ago by felix winkelmann

Mario, thanks for getting involved. This is a situation that will come up again and again, and we need a method of dealing with it.

I contacted Andrei and quickly received a response, where he confirmed his willingness to provide documentation and take over maintenance of the new qt egg. Since the new version greatly enhances the functionality, I'll take the plunge and change the current qt egg to qt-light.

First I have to clean up and test the build, though, since that is a point of divergence between the two branches. Once documentation is provided, I'll switch the eggs.

comment:5 Changed 10 years ago by Mario Domenech Goulart

Very nice, Felix. Good to know that Andrei wants to get in the chicken development/maintenance business.

comment:6 Changed 10 years ago by felix winkelmann

Resolution: fixed
Status: assignedclosed

qt has been renamed qt-light, Andrei takes over maintenance of the new qt egg.

Note: See TracTickets for help on using tickets.