Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#269 closed enhancement (fixed)

Maybe better message for minimum extension requirements

Reported by: Mario Domenech Goulart Owned by:
Priority: not urgent at all Milestone:
Component: core libraries Version: 4.5.x
Keywords: setup-api Cc:
Estimated difficulty:

Description

The error message at http://tests.call-cc.org/2010/06/07/salmonella-report/mw-core.html is

Error: the required extension `"z3"' is older than 1.39, which is what this extension requires

The attached patch makes it look like

Error: the currently installed extension `"z3"' is older than 1.39, which is the minimum version that this extension requires

Does it sound better? I guess so (that's why I'm filling this ticket), but maybe it's just me. Feel free to ignore this patch or to improve it. Maybe the triple-quotes are too much.

Also, the error for mw-core looks weird, since it says that 1.40 is older than 1.39.

Attachments (1)

maybe-better-minimum-version-required-message.diff (977 bytes) - added by Mario Domenech Goulart 12 years ago.
(Maybe) better "minimum version required" message

Download all attachments as: .zip

Change History (3)

Changed 12 years ago by Mario Domenech Goulart

(Maybe) better "minimum version required" message

comment:1 Changed 12 years ago by felix winkelmann

Resolution: fixed
Status: newclosed

Applied in 1e460d3 - thanks very much.

comment:2 Changed 11 years ago by felix winkelmann

Milestone: 4.6.0

Milestone 4.6.0 deleted

Note: See TracTickets for help on using tickets.