Opened 11 years ago

Closed 11 years ago

#267 closed defect (worksforme)

Salmonella sometimes prints [ok] when an egg could not be installed

Reported by: sjamaan Owned by: Mario Domenech Goulart
Priority: major Milestone:
Component: extensions Version: 4.5.x
Keywords: salmonella Cc:
Estimated difficulty:

Description

I ran salmonella '(eggs (lambda () (list "prometheus" "s48-modules")))' from a directory where there was no chicken-eggs directory and it printed:

Installing prometheus                                    [ok]
Installing s48-modules                                   [ok]

Change History (3)

comment:1 Changed 11 years ago by Mario Domenech Goulart

Sorry for the late reply. I cannot reproduce the problem here.

When executing salmonella '(eggs (lambda () (list "prometheus" "s48-modules")))' from a directory where there is no chicken-eggs directory I get:

$ salmonella '(eggs (lambda () (list "prometheus" "s48-modules")))'
salmonella will delete all *.egg and *.egg-dir files and directories under /home/mario.  Proceed? [y/n]: y
Installing prometheus
Error: (directory) cannot open directory - No such file or directory: "/home/mario/chicken-eggs/release/4"

        Call history:

        <eval>          [main] (alist-ref (string->symbol egg) ((egg-information)))
        <eval>          [main] (string->symbol egg)
        <eval>          [main] ((egg-information))
        <eval>          [main] (egg-information)
        <eval>          [main] (not egg-data)
        <eval>          [main] (gather-egg-information (chicken-eggs-dir))
        <eval>          [main] (chicken-eggs-dir)
        setup-download.scm: 96   directory                      <--

comment:2 Changed 11 years ago by felix winkelmann

Milestone: 4.6.0

comment:3 Changed 11 years ago by sjamaan

Resolution: worksforme
Status: newclosed

I can't reproduce it anymore either, I'll just close the ticket.

Note: See TracTickets for help on using tickets.