Opened 11 years ago

Closed 11 years ago

#25 closed defect (fixed)

chicken-install does not order egg version properly

Reported by: Ivan Raikov Owned by: felix winkelmann
Priority: critical Milestone:
Component: infrastructure Version: 4.0.1
Keywords: chicken-install version Cc:
Estimated difficulty:

Description

The latest version of the uri-generic egg is 2.1, yet chicken-install insists on installing version 1.12. Clearly, the code that orders egg versions is broken. I had fixed that issue in chicken-setup in Chicken 3, please refer to the version comparison code there and use it in setup-api.

Change History (4)

comment:1 Changed 11 years ago by felix winkelmann

The problem is that the henrietta CGI instance on chicken.kitten-technologies.co.uk is built with a chicken that doesn't incorporate the recent version-comparison changes.
I have contacted Alaric but are waiting for a response, yet. The henrietta on galinha has been updated and appears to work correctly.

comment:2 Changed 11 years ago by felix winkelmann

Component: build systeminfrastructure
Priority: majorcritical

comment:3 Changed 11 years ago by felix winkelmann

Should work now - please verify and close ticket.

comment:4 Changed 11 years ago by Ivan Raikov

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.