Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#248 closed defect (fixed)

Readline egg will not build without libtermcap

Reported by: ewfalor Owned by: felix winkelmann
Priority: major Milestone:
Component: extensions Version: 4.5.0
Keywords: readline Cc:
Estimated difficulty:

Description

Running chicken-install readline fails with the following error message:


installing readline: ...
changing current directory to /tmp/chicken-install-216.tmp/readline

/usr/local/stow/chicken-4.5.0/bin/csi -bnq -setup-mode -e "(require-library setup-api)" -e "(import setup-api)" -e "(extension-name-and-version '(\"readline\" \"\"))" /tmp/chicken-install-216.tmp/readline/readline.setup
/usr/local/stow/chicken-4.5.0/bin/csc -feature compiling-extension -setup-mode -s -o rlu-test rl-usable-test.scm -lreadline -lhistory -ltermcap

/usr/lib/gcc/x86_64-pc-linux-gnu/4.3.4/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -ltermcap
collect2: ld returned 1 exit status

Error: shell command terminated with non-zero exit status 256: gcc rlu-test.o -o rlu-test -shared -lreadline -lhistory -ltermcap -L"/usr/local/stow/chicken-4.5.0/lib" -Wl,-R"/usr/local/stow/chicken-4.5.0/lib" -lchicken -lm -ldl

shell command failed with nonzero exit status 256:

/usr/local/stow/chicken-4.5.0/bin/csc -feature compiling-extension -setup-mode -s -o rlu-test rl-usable-test.scm -lreadline -lhistory -ltermcap


It appears that the problem is with the check-rllibs syntax in readline.setup. Instead of trying the next combination of -l flags, it completely bails out.

Attachments (1)

readline.setup.patch (840 bytes) - added by ewfalor 11 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by felix winkelmann

Owner: set to felix winkelmann
Status: newassigned

comment:2 Changed 11 years ago by felix winkelmann

Keywords: readline added
Resolution: fixed
Status: assignedclosed

Thanks for reporting this. The setup script was indeed incorrect and has been fixed (hopefully) in r18216. A new version has been tagged and should be available now.
Should there still be problems, please reopen the ticket.

Changed 11 years ago by ewfalor

Attachment: readline.setup.patch added

comment:3 Changed 11 years ago by ewfalor

Resolution: fixed
Status: closedreopened

There is still a problem with the setup script. rl-extralib is now a string value, not a list. The rest of the setup script needs to be modified to treat it as a string. The attached patch does so.

comment:4 Changed 11 years ago by felix winkelmann

Resolution: fixed
Status: reopenedclosed

Argh.

See r18220. Sorry for the dumb mistake.

comment:5 Changed 10 years ago by felix winkelmann

Milestone: 4.6.0

Milestone 4.6.0 deleted

Note: See TracTickets for help on using tickets.