Opened 9 years ago

Closed 9 years ago

#233 closed defect (fixed)

termite compiles but fails to install

Reported by: jeronimo Owned by: ckeen
Priority: major Milestone:
Component: extensions Version: 4.6.0
Keywords: termite egg Cc:
Estimated difficulty:

Description

Hi,

I just tried to install the termite egg with the latest git/HEAD Chicken (bd0ac7d0684da5e1afc4535e6e94f53cff0a9dfd). It compiles but fails to install:

  chmod a+r /usr/local/lib/chicken/5/defstruct.setup-info
installing termite: ...
changing current directory to /tmp/chicken-install-485.tmp/termite
  /usr/local/bin/csi -bnq -setup-mode -e "(require-library setup-api)" -e "(import setup-api)" -e "(extension-name-and-version '(\"termite\" \"\"))" /tmp/chicken-install-485.tmp/termite/termite.setup
  /usr/local/bin/csc -feature compiling-extension -setup-mode    -s termite-chicken.scm -o termite.so -j termite

Error: bad argument count - received 2 but expected 1: #<procedure (delete-duplicates lst)>

	Call history:

	<eval>		[remove] (pred? x)
	<eval>		[filter] (cons (car lst) (filter pred? (cdr lst)))
	<eval>		[filter] (car lst)
	<eval>		[filter] (filter pred? (cdr lst))
	<eval>		[filter] (cdr lst)
	<eval>		[filter] (null? lst)
	<eval>		[remove] (filter (lambda (x) (not (pred? x))) lst)
	<eval>		[filter] (null? lst)	<--

Error: shell command terminated with non-zero exit status 17920: /usr/local/bin/chicken termite-chicken.scm -output-file termite.c -dynamic -feature chicken-compile-shared -feature compiling-extension -setup-mode -emit-import-library termite

shell command failed with nonzero exit status 256:

  /usr/local/bin/csc -feature compiling-extension -setup-mode    -s termite-chicken.scm -o termite.so -j termite

Error: shell command terminated with nonzero exit code
17920
"/usr/local/bin/csi -bnq -setup-mode -e \"(require-library setup-api)\" -e \"(im...

Thanks,
Jeronimo

Change History (4)

comment:1 Changed 9 years ago by felix

  • Owner set to ckeen
  • Status changed from new to assigned

comment:2 Changed 9 years ago by jeronimo

I forgot: the SVN revision is 18068.

comment:3 Changed 9 years ago by jeronimo

Hi,

I was doing some additional tests, and suddenly I could not reproduce the problem anymore -- until I saw that the fix was commited to svn. Thank you for the fast response!
termite installation works now.

J.

comment:4 Changed 9 years ago by ckeen

  • Resolution set to fixed
  • Status changed from assigned to closed

Yes, I did some additional tests before closing the ticket. Thanks for your report!

Note: See TracTickets for help on using tickets.