Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#181 closed defect (invalid)

Problems installing eggs on Mac OS X with Chicken 4.3.7

Reported by: Ivan Raikov Owned by:
Priority: major Milestone:
Component: compiler Version: 4.3.x
Keywords: Cc:
Estimated difficulty:

Description

The following errors occurs when trying to install binary-heap on Mac OS X 10.5 (gcc 4.0.1) , using Chicken 4.3.7:

[some output omitted ...]

/Users/ivan/bin/chicken/bin/csi -bnq -setup-mode -e "(require-library setup-api)" -e "(import setup-api)" -e "(extension-name-and-version '(\"binary-heap\" \"\"))" /tmp/chicken-install-192.tmp/binary-heap/binary-heap.setup
/Users/ivan/bin/chicken/bin/csc -feature compiling-extension -setup-mode -O2 -s binary-heap.scm -j binary-heap

dyld: lazy symbol binding failed: Symbol not found: _C_i_symbolp

Referenced from: /Users/ivan/bin/chicken/lib/chicken/5/datatype.import.so
Expected in: /Users/ivan/bin/chicken/lib/libchicken.dylib

dyld: Symbol not found: _C_i_symbolp

Referenced from: /Users/ivan/bin/chicken/lib/chicken/5/datatype.import.so
Expected in: /Users/ivan/bin/chicken/lib/libchicken.dylib

Error: shell command terminated with non-zero exit status 5: /Users/ivan/bin/chicken/bin/chicken binary-heap.scm -output-file binary-heap.c -dynamic -feature chicken-compile-shared -feature compiling-extension -setup-mode -optimize-level 2 -emit-import-library binary-heap

Error: shell command failed with nonzero exit status
256
"/Users/ivan/bin/chicken/bin/csc -feature compiling-extension -setup-mode -O2 -s binary-heap.scm -j binary-heap"

Call history:

setup-api.scm: 242 run-verbose
display
display
write-char/port
##sys#flush-output
setup-api.scm: 243 $system
setup-api.scm: 753 system
setup-api.scm: 758 error <--

Error: shell command terminated with nonzero exit code
17920
"/Users/ivan/bin/chicken/bin/csi -bnq -setup-mode -e \"(require-library setup-ap...

Change History (5)

comment:1 Changed 12 years ago by felix winkelmann

This may be caused by an old datatype.import.so, if you delete all *.so's and recompile and reinstall, what happens?

comment:2 in reply to:  description ; Changed 12 years ago by Ivan Raikov

The problem was caused by an older Chicken distribution installed in /usr; apparently the compiled .so files were linked incorrectly. Setting LD_LIBRARY_PATH and recompiling all the installed eggs fixes the problem, although perhaps chicken-install could be a little bit smarter about what options to pass to the linker. You can close this ticket if you don't think this is worth the effort.

Replying to iraikov:

The following errors occurs when trying to install binary-heap on Mac OS X 10.5 (gcc 4.0.1) , using Chicken 4.3.7:

comment:3 in reply to:  2 Changed 12 years ago by felix winkelmann

Replying to iraikov:

The problem was caused by an older Chicken distribution installed in /usr; apparently the compiled .so files were linked incorrectly. Setting LD_LIBRARY_PATH and recompiling all the installed eggs fixes the problem, although perhaps chicken-install could be a little bit smarter about what options to pass to the linker. You can close this ticket if you don't think this is worth the effort.

Was this caused by a missing -L<path> option? I'd love to fix this, but am not completely clear about the exact cause of the incorrect link.

comment:4 Changed 12 years ago by Ivan Raikov

Resolution: invalid
Status: newclosed

Well, it looks like I cannot reproduce this bug, so perhaps it did have to do with some old *.import.so files. The options passed to the linker seem to be correct.

comment:5 Changed 12 years ago by (none)

Milestone 4.4.0 deleted

Note: See TracTickets for help on using tickets.