Opened 8 months ago

Closed 3 months ago

#1692 closed defect (fixed)

s11n doesn't work with srfi-69 hash-tables

Reported by: megane Owned by:
Priority: major Milestone: someday
Component: extensions Version:
Keywords: s11n hash-table srfi-69 Cc:
Estimated difficulty:

Description

Trying to use the deserialized hash-table causes a segfault:

(import srfi-69)
(import s11n)

(define (store-and-load o file)
  (with-output-to-file file (lambda [] (serialize o)))
  (with-input-from-file file (lambda [] (deserialize))))

(let ([ht (store-and-load (make-hash-table) "out.ser")])
  (print "ht: " ht)
  (hash-table-set! ht 1 1)) ;; -> segfault

Change History (4)

comment:1 Changed 8 months ago by megane

Resolution: invalid
Status: newclosed

Duplicate of #768

comment:2 Changed 8 months ago by megane

(nothing to see here)

Last edited 8 months ago by megane (previous) (diff)

comment:3 Changed 3 months ago by Idiomdrottning

Resolution: invalid
Status: closedreopened

The duplicate bug was fixed by me but this bug still persists. Will investigate.

comment:4 Changed 3 months ago by Idiomdrottning

Resolution: fixed
Status: reopenedclosed

Now fixed with the fix in #768

Note: See TracTickets for help on using tickets.