Opened 19 months ago

Closed 3 weeks ago

#1680 closed defect (fixed)

henrietta ignores dotfiles

Reported by: Vasilij Schneidermann Owned by:
Priority: not urgent at all Milestone: someday
Component: infrastructure Version: 5.1.0
Keywords: eggs henrietta Cc:
Estimated difficulty: trivial

Description

Files starting with a dot (AKA dotfiles) are ignored when fetched with henrietta. One such example file is https://github.com/wasamasa/breadline/blob/master/examples/.csirc which isn't downloaded by chicken-install.

Change History (4)

comment:1 Changed 18 months ago by sjamaan

Fixed by 1.4 release (TODO: deploy it)

comment:2 Changed 18 months ago by sjamaan

Due to a regression in henrietta-cache, newer versions would no longer take dotfiles from the extracted archive when moving it over to the cache directory.

This has been fixed, so one must now install henrietta-cache 1.6 alongside henrietta 1.4 for this to work smoothly. It also works with henrietta-cache 1.3 or earlier.

comment:3 Changed 3 weeks ago by Vasilij Schneidermann

Thanks, I've run chicken-install breadline and ~/.cache/chicken-install/breadline/examples/.csirc is there now.

comment:4 Changed 3 weeks ago by Vasilij Schneidermann

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.