Opened 3 weeks ago

Closed 9 days ago

#1661 closed defect (fixed)

irregex-replace/all behaves weirdly at bos/bol

Reported by: sjamaan Owned by:
Priority: major Milestone: 5.2
Component: core libraries Version: 5.1.0
Keywords: irregex Cc:
Estimated difficulty: medium

Description

Reported by Petruchio on IRC:

`
(irregex-replace/all (irregex 'bol) "Line1\nLine2" "*")
=>
"ine1\n*Line2"
`

Expected output is "*Line1\n*Line2". If you use bos instead of bol the first character gets "eaten" as well.

Change History (2)

comment:1 Changed 3 weeks ago by sjamaan

Looks like the problem is in irregex-fold/fast, where it skips ahead on the empty match.

comment:2 Changed 9 days ago by sjamaan

Resolution: fixed
Status: newclosed

Fixed with the update to irregex 0.9.7

Note: See TracTickets for help on using tickets.